Nano mit Cuboid und Lüfter

holledauer

New member
Servus beinand,

heute habe ich endlich mal meine Nano (Neueste Software) mit dem Cuboid zusammengeschlossen :)
PIT Einstellung ist Lüfter Kamodo und als PIT-Temperatur ist 25 Grad eingestellt. Die Aussentemperatur ist knapp 29 Grad.
Was ich nicht verstehe ist, dass trozdem immer wieder mal der Lüfter anläuft ....
An was liegt das?

Hier steht der Lüfter wie man an dem Richtungspfeil im Lüfter sehen kann
2018-07-27 19.16.14.jpg

Jetzt läuft der Lüfter obwohl der Pitmaster auf 0% steht..
2018-07-27 19.17.01.jpg

Hhhmmm, hab ich eine Einstellung übersehen oder ist das gewollt?

Hier der Link in die Cloud, da wird aber bei weitem nicht jeder Lüfterlauf angezeigt:
https://cloud.wlanthermo.de/index.html?api_token=82ec265b507a51be
 
Zuletzt bearbeitet:

s.ochs

BOFH
Du hast einen D-Anteil im Regler drin, oder? Die Anzeige im GUI wird alle 3 Sekunden erneuert, gemessen wird aber jede Sekunde und danach arbeitete auch der Regler. Kann also sein, dass die Temperatur zwischen der Anzeige kurz abfällt und durch den D-Anteil der Regler aktiv wird. Bis zur Aktualisierung der Anzeige ist dann die Temperatur wieder gleich wie am Anfang und man sieht keine Veränderung. Am OLED wird jede Sekunde aktualisiert, also Mal dort beobachten. Je nach Fühlertyp nimmt die Analog-Digital-Auflösung bei tieferen Temperaturen (im Vergleich zu den Temperaturen im Grill) recht schnell ab, sodass Schwankungen im 0,1°C Bereich vorkommen können. Im Kamado-Profil ist ein D-Anteil von um die 600 eingetragen. Bei einer Temperaturänderung von 0,1°C wird da kurzfristig also ein Pitmasterwert von 60% erzeugt (nicht 1:1 zu sehen da verrechnet mit P- und I-Anteil).

Nimm den D-Anteil raus, und der Lüfter sollte still sein, wenn die Temperatur über Soll liegt. Der D-Anteil ist eh so eine Sache, häufig kommt man mit einem PI-Regler auch gut hin, gerade bei Systemen die nicht so störanfällig sind.
 

holledauer

New member
Servus Steffen, ich hab an den vorgegeben PID-Werten nix verstellt und es war ja nur ein "Trockentraining". Ich denke, ich lass die Werte jetzt einfach mal so und belüfte damit mal das BGE und dann sehen wir schon :)
Danke für Deine ausführliche Analyse 👍
 
Zuletzt bearbeitet:

s.ochs

BOFH
Wie gesagt, wenn es mit dem D-Anteil nicht so läuft, dann würde ich erstmal mit PI-Regler versuchen. Durch die große Speichermasse im Ei sind kleine Temperaturschwankungen eher selten.
 
Top