Upgrade auf v2 möglich?

JustMeat

New member
Gehts hier um die Default High Low geschichte der Pins oder?
https://www.raspberrypi.org/forums/viewtopic.php?t=132109
Wäre sowas nicht die Lösung dafür? (Hatte ich dir schon mal vor nen Jahr oder so gepostet...) 😆

Dachte ich schon, aber hierzu 2 Probleme:

- der Befehl pigs funktioniert bei mir auf dem aktuellen Softwarestand nicht mehr (s. vorheriger Post)
- das Problem, dass die Mini beim Herunterfahren Pit1 auf High stellt war mir damals nicht bewusst - habe ich nicht getestet (und der Befehl pigs geht jetzt nicht mehr; s.o.)

Die ursprüngliche Problemstellung (Pit 2 bleibt aktiviert, obwohl über die GUI deaktiviert) konnte ich damit jedoch nur temporär lösen - mit dem Workauround (Soll-Temperatur erst unter IST-Temperatur einstellen und danach den Pit deaktivieren) kann ich aber damit leben (dachte nur vielleicht gibt es hierzu bereits eine Lösung).

Grüße und danke nochmals für die Hilfestellungen.
 

DerBurgermeister

New member
Ich habe die Erweiterungsplatine nun mal eingebaut und auf miniV2 umgestellt. Dann kann ich Pit1 und Pit2 sehen.
Wie ist denn nun mit der Erweiterungsplatine die Ansteuerung von Pit1 und Pit2?
Wer steuert nun Lüfter/Servo und wer nur den neuen 12 V Lüfteranschluß?
 

s.ochs

BOFH
Pitmaster 1: GPIO4 (für Lüfter/SSR-12V) und GPIO6 (für Servo/SSR-5V)
Pitmaster 2: GPIO5 (für Lüfter/SSR-12V) und GPIO12 (für Servo/SSR-5V)
Wenn du eine Mini V1 Platine mit der Erweiterungsplatine betreibst, hast du erstmal GPIO4 (Pitmaster 1) und GPIO5 (Pitmaster 2) für Lüfter/SSR-12V zur Verfügung. Vorausgesetzt du hast die Erweiterung mit GPIO5 verbunden. Bei der Mini V2 sitzen die Servo-Anschlüsse auf GPIO6 (Pitmaster 1) und GPIO12 (Pitmaster 2). Wenn du die brauchst, dann entweder direkt als DATA-Leitung nutzen oder mit einem LogicLevelConverter dazwischen. Wurde hier ja schon mehrfach beschrieben. Der ursprüngliche Servo-Anschluss auf der Mini V1 Platine ist ja mit GPIO4 verbunden und daher mit der Einstellung "Mini V2" nicht mehr nutzbar. An der Anschlussbuchse liegt aber ganz simpel 5V/GND und GPIO4 an, also einfach die Verbindung zu GPIO4 durch eine Verbindung zu GPIO6 ersetzen.
 

s.ochs

BOFH
Welcher Servo ist das? Ein GPIO am Pi hat nur ein Spannungslevel von 3,3V beim Zustand HIGH. Für den ein oder anderen Servo eventuell zu wenig, weil die ja mit 5 - 6 V arbeiten. Deshalb der Converter, der das Signal auf 5V transformiert. Nutzt du jetzt GPIO6? Hat der Servo vorher an der V1 mit Einstellung V1 funktioniert?
 

DerBurgermeister

New member
Hallo Steffen,
das ist ein SG90. Der braucht laut Datenblatt 4,8 Volt Spannung und PWM Signal. Ja ich nutze GPIO6. Der Sensor war vorher noch nicht am V1.
 
Top